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Final Cut is a reliable, high-performance editing system. However, there are things you can do to both fix 

and prevent problems. This article focuses on tips to keep your hardware, operating system and project 

files up, running and optimized. (If I've left out something you feel is important, let me know so I can 

update the article.)

There isn't enough space to provide the "why" behind all these recommendations. Where possible, links 

are provided so you can read more about it.

This article is divided into the following sections:

Regular maintenance

Simple things to check

Simple ways to prevent problems

Optimizing your system

More advanced ways you can prevent problems

Upgrades

Helpful repair utilities

REGULAR MAINTENANCE

Safe Boot & Rebuild Permissions

The biggest consistent problem I've seen with OS X is confused disk directories. Normally, directories get 

written to the disk when you shut down or restart. And, normally, everything works fine. However, if a 

crash, or some other accident, occurs these directories may not get properly updated. A good test as to

whether you need to run this procedure is when your Mac takes longer than about 30 seconds to shut 

down. 

Once a week, or whenever you upgrade an application, or whenever you upgrade your operating system, 

or whenever you have a crash, or when your Mac takes longer than about 30 seconds to shut down, do the 

following:

1. Restart your computer holding the SHIFT key down.

2. When the blue screen appears, let go of the Shift key (notice the words, "Safe Boot" that appear on 

the screen)

3. When your system boots, go to Applications -> Utilities -> Disk Utility

4. Open "Disk Utility"

5. Select your boot disk

6. Run "Repair Permissions"

7. When done, restart your computer



For more information, click here [File Journaling]

Trash Preferences

Preference files get corrupted during a crash, force quit, or some other natural disaster. When preference 

files get hosed, Final Cut loses a great deal of its stability. To regain it's equilibrium, do the following:

1. Go to: Users/[your user name]/Library/Preferences

2. Drag, "com.apple.FinalCutPro.plist" to the trash

3. Scroll down to the Final Cut Pro folder

4. Drag, "Final Cut Pro 4.0 Preferences" to the trash

5. Drag, "Final Cut Pro POA Cache" to the trash

When you trash preferences, you will lose all Favorite motions, transitions and effects; the list of your 

recent projects and any custom window and button arrangements that were not saved to disk. Note: you 

DON'T lose your project files, simply the list of them in the "Open Recent" menu.

Also, when you trash preferences, you need to trash all three as a group. Don't just trash one.

Click here for more info: [ ]Trashing preferences

Allow your Unix background utilities to run

The foundation for OS X is Unix and Unix was invented specifically to run servers; systems that needed to 

stay on for long periods of time.

Because of this, a variety of system utilities were developed to run in the background to keep the 

operating system running at peak efficiency. However, as these utilities should not interfere with the 

normal operation of the server, they were programmed to run in the wee small hours of the weekend 

night. 

Which means that if you regularly shut your system down each night, these utilities don't get the 

opportunity to run.

To solve this, you have a number of options:

1. Let your system stay on over the weekend at least once a month.

2. Or, install a utility program that will run these programs for you automatically. I personally like 

Macaroni ( ), but others also like Mac Janitor (

). There are others to choose from, as well.

www.atomicbird.com http://personalpages.tds.net/

~brian_hill/macjanitor.html

In any case, give your Mac a chance to stay healthy.

Setting Ownership Permissions on External Drives

Ownership permissions play an important role in helping OS X figure out who has permission to do what 

on your computer. However, when it comes to editing video, permissions can get in the way. 

To keep things running smoothly, 

1. In the Finder, select every hard drive EXCEPT your boot drive.

2. Go to File -> Get Info

3. Twirl down "Ownership and Permissions"

4. Select the checkbox next to "Ignore ownership on this volume."

5. Close the Get Info box.

This means that OS X will no longer worry about whether a user has the right to access the information 

contained on your media drives. This prevents problems where one user can record to, or playback from, 

a drive and other users can't.

Set all non-boot drives to "Not Journaled."



Journaling is a new feature in OS 10.3.x that helps your Mac to recover after a crash. (See: 

.)

OS X 

Journaling Explained

However, it can also decrease the performance of your media drives.

My recommendation is to leave journaling ON for your boot disk, which is the default, then go to Disk 

Utility and select all your media drives. Go to File -> Disable Journaling and turn Journaling OFF for all 

media drives.

Also, in the past, in OS 9, we worried a lot about file fragmentation. In OS X, with large hard disks, this is 

not something to worry about. So, don't.
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SIMPLE THINGS TO CHECK

This list could actually be hundreds of items long, but here are four favorites, based on how often I hear 

them.

1. You can't see video on your external NTSC monitor. Make sure BOTH the Viewer and Canvas 

windows are set to Fit to Window. Then, if you are using DV, make sure View -> External Video is 

set to "All."

2. You've imported a still image, but can't see it on the timeline. Make sure all imported images are 

RGB. CMYK images (frequently used in graphic design and printing) won't display in Final Cut.

3. You don't have any audio. Go to Final Cut Pro -> Audio/Video settings and make sure the Audio 

playback 

menu is sending audio out the right port for your monitor.

4. Audio and video are out of sync. If there are red flags at the start of your clip, control click on the 

red flag of your video and select "Move into sync." If there are no red flags at the start of your clip, 

go to Final Cut Pro -> Audio/Video settings and make sure the Video playback and Audio playback 

are both set to the same point. For instance, monitoring video via Firewire and audio via Built-in 

audio will automatically be out of sync by around 6 frames.

Click here for more "simple things" to check:  ][ FCP FAQ
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SIMPLE WAYS TO PREVENT PROBLEMS

There are a number of things you can do that will keep your system running smoothly.

1. Make sure your hard disks are never more than 85% full. Hard disks need lots of room to create 

temporary files. If a hard disk gets too full, it can lock up and prevent both writing and reading 

data. Go to Final Cut Pro -> System Settings -> Scratch disks and set the "Minimum Allowable Free 

Space On Scratch Disks" equal to 15% of your largest hard disk.

2. For larger projects that will take longer than a day or two to edit, make a point of doing a "Save 

as..." at the end of editing every day. Doing a "Save as..." will automatically clean up any potential 

problems in your project file, before they become serious. This also has the added benefit of giving 

you reliable back-ups every night for your project. 

In naming my projects, I use version numbers ("My Project v1, v2, v3... and so on.) You can also 

use dates ("My Project 0315, 0316, 0317...). Save as... is better than duplicating the project in the 

Finder because duplicating a project doesn't fix problems. Save as... does.

3. Avoid creating Browser nests which are too deep. Although the Browser allows you to put files up to 

eight levels deep, try to avoid going much more than 4 or 5 layers. Sometimes, the Browser can get 

too complex for it's own good.

4. Don't have too many sequences open in the Timeline at the same time. Sequences require memory 

when they are opened in the Timeline. Sequences in the Browser don't use memory. So, if you are 



limited in the memory you have on your system, keep the number of Sequences open in the 

Timeline to a minimum.

5. If you have a sequence that is acting flakey:

a) Create a new sequence

b) Go back to the flakey sequence and Edit -> Select All

c) Copy the entire selected sequence to the clipboard (Edit -> Copy)

d) Go to the newly created sequence

e) Move your Playhead to the start of the new sequence

f) Paste (Edit -> Paste)

Often, moving clips from one sequence to another fixes problems.
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OPTIMIZING YOUR SYSTEM

Normally, on a reasonably fast computer, the default installation of OS X and Final Cut Pro works 

perfectly. If your system is working fine now, you can ignore these suggestions. If not, try these 

suggestions to see if things improve. (This list has been modeled on one supplied by Pinnacle Systems for 

it's Cinewave card.)

These are not necessarily listed in any particular order. 

Optimize Your System Preferences

1. In the “Login Items” System Preference Pane, remove any items that automatically start when you 

log in. 

2. In the “Screen Effects” System Preference Pane, set “Time until screen effects start” to “Never.”

3. In the “Display” System Preference Pane, set the “Colors” to “Millions.” 

4. In the Energy Saver System Preference Pane, set “Put the computer to sleep when it has been 

inactive” to “Never;” and “Put the hard disk to sleep when possible” should not be checked. 

5. In the Sound System Preference Pane, select the “Sound Effects” tab. Turn the “Output volume” all 

the way up, then back up one notch, and lower the “Alert volume” to the desired level. 

6. In the QuickTime System Preference Pane, select the “Update” tab, and deselect “check for updates 

automatically.”

7. In the “Sharing” System Preference Pane, disable all services. The Firewall should be off. Internet

sharing should be off.

8. In the Date and Time System Preference Pane, the Menu Bar Clock should be disabled. The option to 

“"Use a Network Time Server”" should be deselected. 

9. In the Software Update System Preference Pane, “Automatically check for updates when you have a 

network connection" should be unchecked.

10. , go to the Security Preference Pane and turn OFF File Vault. While having 

the extra security is nice, your Mac can't decrypt FCP Project, or other files, fast enough to ensure

smooth playback.

If you have OS X 10.3.x

Notice that our goal is to minimize processes that run in the background, or that call out to the network. 

You probably won't need to use all these settings. Experiment to see which ones work best for you.

Also, once you stop editing, you can turn on those features that you need (with the exception of File 

Vault). If you need to use File Vault be sure that NONE of the files used in your project are stored in it. 

Then, you can leave it on, just not access it during editing.

Finally, after making these changes, quit out of the System Preferences utility before launching any 

application -- especially Final Cut.

Optimize Your Final Cut System 

Here are some additional steps you can take to improve the performance of your Final Cut system.

1. Turn off audio waveforms (Option-Command-W). If you aren't actually editing audio, displaying 

these will slow your system down.



2.  and you have more than 512 MB of RAM and are using still images (say, to 

create a "Ken Burns" effect) go to Final Cut Pro -> System settings -> Memory and Cache tab and 

set the still image cache to between 100 MB and 120 MB.

If you have FCP 4.x

3.  and if you have more than a gigabyte of RAM on your system, also set the 

Memory allocation to 90%.

If you have FCP 4.x
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MORE ADVANCED WAYS YOU CAN PREVENT PROBLEMS

1. Add more RAM to your system. Final Cut requires a minimum of 384 MB. However, I strongly 

suggest you have at least one gigabyte in your system. I have 2.5 GB in mine. Adding more RAM 

beyond 2 GB won't make a material difference, because FCP is disk-based, not RAM based. 

However, you will notice a significant performance increase by increasing your RAM from a base 

level of 512 MB to 1 GB.

2. If playback is stalling, try disconnecting some, or all, of your Firewire drives. Although the Firewire 

spec allows up to 63 devices to be connected to your computer, after about five or six drives, 

there's so much "talking" on the Firewire bus that performance really starts to degrade. Where 

possible, limit the number of Firewire drives you are using. Worst case, buy bigger drivers and copy 

data from smaller drives to bigger drives so you total storage remains the same, but the number of 

devices decreases.

3. If you are constantly getting dropped frames on playback, it may be easier to export the sequence 

than to try to fix it. In this case:

a) Export your timeline to a QuickTime movie (which happens at computer speeds as opposed to 

real-time). Be sure to set the export to "Current Settings."

b) Create a new project

c) Import your QuickTime movie into the new project

d) Play out the new movie

4. Sometimes errors creep into the User file. In this case, creating a New User will solve it.

a) Save your project file OUTSIDE of your User folder and NOT on the desktop

b) Go to System Preferences

c) Go to Accounts

d) Click the "+" key to add a new user

e) Fill out the rest of the screen

f) Log out as your current user and log in as the new user

g) Open your project and see if things are better

5. Reinstall the Final Cut application. Like I said, these last three suggestions require a fair amount of 

time. On the other hand, if you are still having problems, they are the next thing to check.

6. Reinstall all upgrades by downloading FIRST, then updating using the package. Don't use Software 

Update.

7. Do a clean install of the Operating System -- be sure to run all updates afterward. The best versions 

of OS X to use for Final Cut Pro are 10.2.8 and 10.3.2. 
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UPGRADES

It used to be that when a new upgrade rolled out, all we needed to do was upgrade the affected 

application. With video editing this is absolutely the WRONG thing to do.

Video editing requires a complete system level approach to upgrading.

For instance, when 10.2.6 came out, there were so many "under-the-hood" changes that a very popular 

RAID vendor needed to upgrade its drivers. When 10.2.8 came out, the drivers needed to be updated 

again, for the same reason. When 10.3 came out, the drivers needed to be updated, again.

For this reason, you can no longer assume that the only thing needing to be upgraded is FCP itself. 

Here is a list of what needs to be considered when upgrading.



If you are using DV (MiniDV, DVCAM, or DVCPRO-25 gear) upgrade in this order ONLY:

1. Upgrade the operating system

2. Upgrade QuickTime

3. Upgrade Final Cut Pro

4. Upgrade the other applications in the FCP suite

If you are working with SCSI cards, RAIDs, uncompressed video and a capture card, upgrade in THIS 

order:

1. Upgrade your SCSI card FLASH ROM (if necessary)

2. Upgrade your SCSI card driver (if necessary)

3. Upgrade your RAID driver (if necessary)

4. Upgrade your operating system

5. Use Software Update to install any operating system updates

6. Do a Safe Boot and Rebuild Permissions (see the beginning of this article)

7. Restart

8. Upgrade QuickTime

9. Upgrade Final Cut

10. Upgrade any additional applications

11. Upgrade any drivers you are using for machine control

12. Run Software Update to install any new versions of the applications

13. Do a Safe Boot and Rebuild Permissions

14. Run Software Update one more time. Frequently, one update needs to be installed before a second 

update can be installed. This process checks for both.

I got myself in a serious mess recently by not updating the SCSI drivers for a couple of my clients. I was 

at a complete loss to explain why, after I updated the system, performance slowed to a crawl. When I 

realized I had done an incomplete update, then installed the correct SCSI drivers, performance was 

restored and everything worked great. (Whew!)

If possible, doing a clean install of the operating system is the best. (That means erasing your hard disk 

and installing everything fresh.) However, that is not always possible. Nor is it always required. By 

following these steps, in this order, you can save yourself a lot of problems down the road.
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HELPFUL REPAIR UTILITIES

System utilities have always been a significant cottage industry for the Macintosh and today is no 

exception.

Here are three that I recommend:

1. Disk Warrior X (version 3.1) This utility is indispensable for restoring corrupted disk directories. It is 

a one trick pony, but nobody does it better. I carry this CD with me everywhere. Run it once a 

month on your system to keep things working the way you expect. (If you have OS X 10.3, be sure 

to get version 3.0.1.)

2. Tech Tool Pro (version 4.01). This system test and maintenance tool can help you spot trouble 

before it occurs. While I do have a quibble about how it's video display test works (it seems to find 

a great number of false positives) overall it has earned the right to be in my daily repair kit. Only 

run this when you need it. But keep it close at hand.

3. Macaroni. I use this for all my support clients to make sure key background Unix utilities run in a 

timely fashion. This is from the "install it once and forget it" school of thought, but I like it and use it

on both my client and personal systems.

CONCLUSION

Two other quick thoughts. While religious wars continue to be fought on both these issues, I wanted to 

weigh in on both:



1. Partitioning

2. De-fragmenting

Based on talking with drive vendors, partitioning is not necessary. If it helps you stay organized -- use it. 

But there is, generally, no performance benefit to partitioning. If, on the other hand, you want to have two 

different boot disks using two different operating systems, partitioning is the way to go. However, 

partitioning is often wasteful of hard disk space. The short answer is, if you are looking for speed, you 

don't need to partition. If you are looking for organization, partitioning is OK.

However, NEVER store media files on a partitioned disk. Media should always be stored on a second drive.

De-fragmenting was necessary when hard disks were smaller and systems were slower. With today's 

technology, if it makes you feel better to de-frag, then by all means, go-ahead. However, you will not see 

a significant performance boost. Nor is it necessary. Nor does Final Cut particularly care. Because when

FCP is playing video back, the hard drive heads are bouncing all over the place anyway. Decreasing the 

fragmentation won't help a whole lot.

Well, that's about it. These are procedures you can use to keep your system running at peak performance. 

If I've omitted one of your favorites, let me know so I can periodically update this article.

In the meantime, it's time to stop trouble-shooting and start editing. 

This article is from the March issue of " " a very cool FREE monthly Final Cut Pro 

newsletter -- subscribe at Larry's web site: . Larry Jordan is a post-production 

consultant and an Apple-Certified Trainer in Digital Media with over 25 years experience as producer, 

director and editor with network, local and corporate credits. Based in Los Angeles, he's a member of both 

the Directors Guild and Producers Guild. 
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